[gnutls-devel] GnuTLS | git clone error on ubuntu 19.04 (#769)

Development of GNU's TLS library gnutls-devel at lists.gnutls.org
Thu May 16 21:37:33 CEST 2019

New Issue was created.

Issue 769: https://gitlab.com/gnutls/gnutls/issues/769
Author:    BigGosh

## Description of problem:
I run the command 

`git clone https://github.com/creationix/nvm.git -b v0.34.0 --depth=1`

and the following error is displayed:
> fatal: unable to access 'https://github.com/creationix/nvm.git/': GnuTLS recv error (-54): Error in the pull function. 

I've tried with many different github reposiroties

Obviously the link is correctly accessible from my network.

If I recompile git without GnuTLS but with OpenSSL git works fine.
I've opened a bug on ubuntu but they said me it's not a their problem (Bug 1826598 - 
> https://bugs.launchpad.net/ubuntu/+source/git/+bug/1826598 ).

## Version of gnutls used:

## Distributor of gnutls (e.g., Ubuntu, Fedora, RHEL)
ubuntu 19.04

## How reproducible:

Steps to Reproduce:

 * run the command `git clone https://github.com/creationix/nvm.git -b v0.34.0 --depth=1` 
 * wait some timeout
 * see the error

## Actual results:
An error

## Expected results:
The clone of the repository

Reply to this email directly or view it on GitLab: https://gitlab.com/gnutls/gnutls/issues/769
You're receiving this email because of your account on gitlab.com.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.gnupg.org/pipermail/gnutls-devel/attachments/20190516/fd34f012/attachment.html>

More information about the Gnutls-devel mailing list