[gnutls-devel] GnuTLS duplicate symbols

Dennis Philipps dennis.philipps at gmail.com
Fri Feb 21 19:01:00 CET 2014

Hi Nikos,

sorry for the late reply. I didn't have a chance to test the GIT version as
up until now. But as I am now observing a SEGFAULT in the ASN1 parser
during client handshake (communicating with a server that runs the same
GnuTLS version and works fine with CURL, Chrome, etc....) I was considering
to checkout the GIT version and to build GnuTLS to see if this fixes the
broken situation.

I observed:

rnd-common.c:174: error: redefinition of typedef 'get_entropy_func'

I removed the definition from the .c translation unit, as it redefined it
from rnd-common.h. This worked. However:

rm -f en at boldquot.gmo && /opt/local/bin/msgfmt -c --statistics --verbose -o
en at boldquot.gmo en at boldquot.po
en at boldquot.po:47: 'msgid' and 'msgstr' entries do not both end with '\n'
(last line is repeated 228 times for like every third or fourth line in
that file) - ends with:
/opt/local/bin/msgfmt: found 228 fatal errors

Well, this is no wonder if you look at it (including the en at quot.po). Some
automation thing has obviously broken these files.

I just removed every \n from the strings to get further. But not very much:


no such file or directory (I am using OS X 10.7.5)... but I just placed a
bash script "return 0" there with a chmod+x

No rule to make target `srptool-args.h', needed by `all'.

I followed the steps from the GnuTLS web page:


using 'make autoreconf'

No luck :( If I was more versed with the autotools suite I would look into
that aswell but I can't invest that much time into autotools atm ;)

Well. So much for testing whether your previous bugfix worked. I hope this
report helps you a bit.

// Dennis

2014-02-03 22:26 GMT+01:00 Dennis Philipps <dennis.philipps at gmail.com>:

> Hello,
> the GnuTLS library since 3.2.x seems to have an issue on the X86
> accelerated code-base. The files
> lib/accelerated/aes-cbc-x86-aesni.c
> lib/accelerated/aes-cbc-x86-ssse3.c
> both define the symbol
> unsigned int _gnutls_x86_cpuid_s[4];
> which results in the duplicate symbols linker error. I assume this is a
> copy/paste/typo something bug. Linking works fine with 3.1.20 (latest 3.1.x
> version as it seems). I patched the files locally and the linking was okay.
> I built on Mac OS X 10.7 but this should probably be found on any x86
> accelerated build as this is not an issue within the assembler code.
> Regards
> Dennis Philipps
-------------- next part --------------
An HTML attachment was scrubbed...
URL: </pipermail/attachments/20140221/9bc1ca19/attachment.html>

More information about the Gnutls-devel mailing list