[gnutls-devel] SIGSEGV in _gnutls_ciphertext2compressed

Michael Gratton mike at vee.net
Thu May 16 05:05:41 CEST 2013

On 03/05/13 04:06, Daniel Kahn Gillmor wrote:
> I tried to replicate the bug report you describe using epiphany-browser
> 3.4.2-2.1 and libgnutls26 2.12.20-6 (the version in wheezy) but was
> unable to reproduce it.
> I tried it with:
>  epiphany-browser http://mod.gnutls.org/
> since i know that should redirect to https://mod.gnutls.org/
> but i got no segfault.  are you able to replicate the segfault using the
> command above?  if so, please report it to your distro at
> https://bugs.launchpad.net/ubuntu/+source/gnutls26/+filebug and follow
> up on this list with the link to the report.

Sorry, I can't seem to reproduce it either. I'm sure there was a
specific example of a web site that does cause it, since I would have
had to installed the relevant -dbg packages and restarted to get the
trace, but I'm not sure what that is now.

From memory, it may have something to do with specific TLS features the
site was using?


⊨ Michael Gratton, Percept Wrangler.
⚙ <http://mjog.vee.net/>

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 261 bytes
Desc: OpenPGP digital signature
URL: </pipermail/attachments/20130516/29e5012a/attachment.sig>

More information about the Gnutls-devel mailing list