[gnutls-devel] SIGSEGV in _gnutls_ciphertext2compressed

Daniel Kahn Gillmor dkg at fifthhorseman.net
Thu May 2 20:06:28 CEST 2013

On 05/02/2013 01:44 PM, Nikos Mavrogiannopoulos wrote:
> On Mon, Mar 4, 2013 at 6:03 AM, Michael Gratton <mike at vee.net> wrote:
>> Using Epiphany, loading a HTTP URL that redirects to a HTTPS URL,
>> results in the attached stack trace.
>> Ubuntu 12.10
>> libgnutls26:amd64       2.12.14-5ubuntu4.2
> Hello,
>  This is from an unsupported (by me at least) version of gnutls. You
> may want to contact your distribution directly about it or upgrade to
> the latest (and supported) gnutls releases.

Hi, i'm a debian develper who wants to support debian gnutls packages at
least, and we'll be (trying to) support some releases from the 2.12
branch (SONAME 26) for the lifetime of the upcoming wheezy release.

I tried to replicate the bug report you describe using epiphany-browser
3.4.2-2.1 and libgnutls26 2.12.20-6 (the version in wheezy) but was
unable to reproduce it.

I tried it with:

 epiphany-browser http://mod.gnutls.org/

since i know that should redirect to https://mod.gnutls.org/

but i got no segfault.  are you able to replicate the segfault using the
command above?  if so, please report it to your distro at
https://bugs.launchpad.net/ubuntu/+source/gnutls26/+filebug and follow
up on this list with the link to the report.



-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 1027 bytes
Desc: OpenPGP digital signature
URL: </pipermail/attachments/20130502/f8a53c0a/attachment.sig>

More information about the Gnutls-devel mailing list