gnutls-2.2.1 fails to build on HP-UX

Dr. David Kirkby david.kirkby at
Sun Nov 29 02:19:09 CET 2009

Simon Josefsson wrote:
> "Dr. David Kirkby" <david.kirkby at> writes:
>> In the Sage project, gnutls is causing a problem on both OpenSolaris
>> and HP-UX. The latter is not a supported OS, but I have tried building
>> parts of Sage on it.
>> This is the HP-UX error.
>> Any thoughts why this may be happening?
> HP-UX doesn't have sockaddr_storage, but I believe gnulib should work
> around that problem -- however that is probably only in much more recent
> GnuTLS releases than the 2.2.1 that you used.
>> We tried a later version, and that was causing problems not only on
>> HP-UX and OpenSolaris, but also on Solaris 10 (SPARC).
> Details?  The recent releases should work relatively fine on Solaris,

See the other thread

"gnutls failure on Solaris 10 update 7 gcc 4.4.1"

(sorry, I should have put the version of gnutls in the title, but it is 
documented in the email)


More information about the Gnutls-devel mailing list