gnutls-2.2.1 fails to build on HP-UX

Simon Josefsson simon at
Thu Nov 26 11:18:19 CET 2009

"Dr. David Kirkby" <david.kirkby at> writes:

> In the Sage project, gnutls is causing a problem on both OpenSolaris
> and HP-UX. The latter is not a supported OS, but I have tried building
> parts of Sage on it.
> This is the HP-UX error.
> Any thoughts why this may be happening?

HP-UX doesn't have sockaddr_storage, but I believe gnulib should work
around that problem -- however that is probably only in much more recent
GnuTLS releases than the 2.2.1 that you used.

> We tried a later version, and that was causing problems not only on
> HP-UX and OpenSolaris, but also on Solaris 10 (SPARC).

Details?  The recent releases should work relatively fine on Solaris,
we've merged several patches for it lately.  Unless you back-port
security fixes to 2.2.x, you want to use the 2.8.x release to get proper
security fixes.

> If any developer needs access to a Solaris 10 (SPARC) or HP-UX 11.11
> (PA-RISC) processor, I can provide it. The SPARC is a newish 16-core
> machine. The latter is an old machine I personally own, but do allow
> others access to it.

You sent me login info on this earlier (thanks!), but I haven't had time
to test it yet -- will try to do it soon.


More information about the Gnutls-devel mailing list