2.7.12 test suite error on chainverify

Andreas Metzler ametzler at downhill.at.eu.org
Sat May 23 13:50:37 CEST 2009


The chainverify test does not complete successfully anymore. 

This is rather strange, it worked two days ago (on the 21st).

Strange data points:
 * This is not limited to my local system.
 * Neither build-depencies nor toolchain (gcc, g++, binutils) nor
   kernel has changed.
 * I still had the build tree of 2.7.11 including all binaries from
   2009-05-19. If I run this old chainverify binary I still get the
 * It fails both on up to date Debian sid and Debian lenny.

The only thing I can think of that has changed for sure is the date.
Hmm. Is this the cause?

Chain 'v1ca ok' (15)...
   Adding certificate 0...done
   Certificate 0: subject `C=US,ST=Illinois,L=Du Page,O=Argonne
   National Laboratory,CN=auth2.it.anl.gov', issuer `C=US,O=VeriSign\,
   Inc.,OU=VeriSign Trust Network,OU=Terms of use at
   https://www.verisign.com/rpa (c)05,CN=VeriSign Class 3 Secure Server
   CA', RSA key 1024 bits, signed using RSA-SHA, activated `2008-05-05
   00:00:00 UTC', expires `2009-05-22 23:59:59 UTC', SHA-1 fingerprint

cu andreas
`What a good friend you are to him, Dr. Maturin. His other friends are
so grateful to you.'
`I sew his ears on from time to time, sure'
-------------- next part --------------
A non-text attachment was scrubbed...
Name: success.gz
Type: application/octet-stream
Size: 2908 bytes
Desc: not available
URL: </pipermail/attachments/20090523/6fc5fc02/attachment.obj>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: error.gz
Type: application/octet-stream
Size: 2925 bytes
Desc: not available
URL: </pipermail/attachments/20090523/6fc5fc02/attachment-0001.obj>

More information about the Gnutls-devel mailing list