[gnutls-dev] API comment

Nikos Mavroyanopoulos nmav at hellug.gr
Sun Jan 20 08:54:02 CET 2002

On Sat, 19 Jan 2002 20:56:40 +0100 Simon Josefsson <simon+gnutls-dev at josefsson.org> wrote:

> From gnutls.h:
> GNUTLS_BulkCipherAlgorithm gnutls_cipher_get_algo( GNUTLS_STATE 
> state); GNUTLS_KXAlgorithm 	    gnutls_kx_get_algo( 
> GNUTLS_STATE state); GNUTLS_MACAlgorithm 
> gnutls_mac_get_algo( GNUTLS_STATE state); GNUTLS_CompressionMethod 
> gnutls_compression_get_algo( GNUTLS_STATE state); 
> IMHO abbrevations ("algo") are bad in the long run, but in this 
> case it might better to remove the "_algo" part alltogether (only 
> two of the four things are algorithms, the other are 
> 'methods'). It also makes it consistent with the names of 
Well it may not look nice, but algorithm applies to all of them.
We have encryption algorithms (ciphers), mac algorithms,
key exchange algorithms (the diffie hellman algorithm),
and even compression algorithms (the deflate algorithm).
Even if rfc2246 calls them methods, I do not believe this is a
major problem.

> (Maybe #define the old names to the new ones for a couple of major 
> releases.)
Changing the api that way means that the next versions would not be
binary compatible. I'll try to keep binary and source compatibility
for versions which have the same minor number (ie 0.3.x should be
binary compatible for every x).

Nikos Mavroyanopoulos
mailto:nmav at hellug.gr

More information about the Gnutls-devel mailing list