[gnutls-devel] valgrind test openpgp-certs woodo

Alon Bar-Lev alon.barlev at gmail.com
Sun Mar 12 14:16:32 CET 2017


I go this strange error in openpgp-certs and only in this test when
running under valgrind. I could not find any reason for this so I
describe what I do get.

To make it short, after configure edit tests/cert-tests/Makefile and
leave only openpgp-certs in TESTS.

Then run make check, I experience the following valgrind error that
fails the test:
Checking OpenPGP certificate verification
==25840== Conditional jump or move depends on uninitialised value(s)
==25840==    at 0x401A5D8: index (in /lib64/ld-2.23.so)
==25840==    by 0x4007DEF: expand_dynamic_string_token (in /lib64/ld-2.23.so)
==25840==    by 0x4007F84: fillin_rpath (in /lib64/ld-2.23.so)
==25840==    by 0x400874B: _dl_init_paths (in /lib64/ld-2.23.so)
==25840==    by 0x4002E21: dl_main (in /lib64/ld-2.23.so)
==25840==    by 0x401820B: _dl_sysdep_start (in /lib64/ld-2.23.so)
==25840==    by 0x4004EC8: _dl_start (in /lib64/ld-2.23.so)
==25840==    by 0x4000CB7: ??? (in /lib64/ld-2.23.so)
==25840==    by 0x7: ???
==25840==    by 0xFFEFFFAEA: ???
==25840==    by 0xFFEFFFB4B: ???
==25840==    by 0xFFEFFFB56: ???
Failure: Connection to signed PGP certificate should have succeeded!
(error code 15)
FAIL openpgp-certs (exit status: 1)

Interesting... if I run only the test using the following command it passes!

$ rm openpgp-certs.log && make openpgp-certs.log

I tried to compare the environment/usage and found nothing. I noticed
the ss failures so prepared this[1] but errors to be harmless.

Then found that the following does pass!!!
PATH=$PATH:/usr/sbin:/sbin make check

I tried to figure out where the problem comes from but could not... I
thought you may have a better idea. Something in this specific test
that uses the same utilities as any other similar tests is doing
something special.


[1] https://gitlab.com/gnutls/gnutls/merge_requests/300

More information about the Gnutls-devel mailing list