[gnutls-devel] Handshake issue with windows-version of GnuTLS with GnuTLS 3.2.7 / 3.2.8

user100 user100 at lisec.com
Tue Jan 21 15:06:50 CET 2014

Handshake does not work anymore on Win8 64bit with GnuTLS 3.2.7 or 
GnuTLS 3.2.8 - binaries from ftp://ftp.gnutls.org/gcrypt/gnutls/w32/ 
(app is 32bit too). Previous versions (including 3.2.6) worked pretty 
well. Following is the gnutls log at a missing handshake with 3.2.8 (WSA 
did not report an error ... and as already written 3.2.6 worked well):
EXT[04B35BF0]: Sending extension SIGNATURE ALGORITHMS (28 bytes)
HSK[04B35BF0]: CLIENT HELLO was queued [249 bytes]
HWRITE: enqueued [CLIENT HELLO] 249. Total 249 bytes.
HWRITE FLUSH: 249 bytes in buffer.
REC[04B35BF0]: Preparing Packet Handshake(22) with length: 249 and min 
pad: 0
ENC[04B35BF0]: cipher: NULL, MAC: MAC-NULL, Epoch: 0
WRITE: enqueued 254 bytes for 000002D0. Total 254 bytes.
REC[04B35BF0]: Sent Packet[1] Handshake(22) in epoch 0 and length: 254
HWRITE: wrote 1 bytes, 0 bytes left.
WRITE FLUSH: 254 bytes in buffer.
ASSERT: gnutls_buffers.c:408
errno: 5
ASSERT: gnutls_buffers.c:192
WRITE error: code -53, 254 bytes left.
ASSERT: gnutls_buffers.c:650
ASSERT: gnutls_handshake.c:2675
Error is fatal: Error in the push function.

More information about the Gnutls-devel mailing list