[gnutls-devel] mini-xssl test fails on mips

Daniel Kahn Gillmor dkg at fifthhorseman.net
Wed May 29 22:55:20 CEST 2013

On 05/29/2013 02:42 PM, Nikos Mavrogiannopoulos wrote:
> On 05/29/2013 08:21 PM, Daniel Kahn Gillmor wrote:
>>> If valgrind is available on this platform would it be possible to run
>>> the program with it and send me the output?
>> i tried to do this, but i'm seeing valgrind errors on mipsel that
>> prevent me from getting anywhere, sorry:
>>   http://bugs.debian.org/710307
> I think I've found the issue. It's a crash on the mini-xssl test itself.
> A fix should be:
> https://gitorious.org/gnutls/gnutls/commit/0ff6b5afae291027c18a43c7d079f3685295fbc4

I tried applying 0ff6b5afae291027c18a43c7d079f3685295fbc4 to 3.1.11 and
it did not fix this failure.

this changeset seems to only change the size of two variables (from 2 to
6 elements of "aux" in both client() and server(), and add a bunch of
verbose output.

Interestingly, running "./mini-xssl --verbose 2>&1 | grep -C3 running"

produces non-deterministic output.  Sometimes, it shows just "running
test1:" and associated code, and other times it shows test1 and test2,
and occasionally i can get it to show test3.

Do you want me to test some other patch?


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 1027 bytes
Desc: OpenPGP digital signature
URL: </pipermail/attachments/20130529/423940ac/attachment.sig>

More information about the Gnutls-devel mailing list