Gnutls 3.0.16 fails due to autoopts header mismatch

Kris Karas ktk at
Fri Mar 16 23:25:35 CET 2012

Just tried compiling the new gnutls 3.0.16:

	serv-args.h:62:3: error: #error option template version mismatches autoopts/options.h header
	serv-args.h:63:3: error: unknown type name 'Choke'
	serv-args.h:63:11: error: expected '=', ',', ';', 'asm' or '__attribute__' before '.' token

Poking around, it seems that the version of GNU autogen used to convert 
src/serv-args.def into src/serv-args.h has placed

	#define AO_TEMPLATE_VERSION 147460

into that header, whereas in src/libopts/autoopts/options.h there is


which is what triggers the version mismatch and error.

FWIW, I compiled and installed autogen-5.15 and re-built the src/*.{h,c} 
from the src/*.def and everything worked OK, a gratuitous install of 
/usr/lib/ notwithstanding.

Kris Karas

-------------- next part --------------
An HTML attachment was scrubbed...
URL: </pipermail/attachments/20120316/3fdc9909/attachment.htm>

More information about the Gnutls-devel mailing list