Why p11-kit-1 instead of p11-kit?

Nikos Mavrogiannopoulos nmav at gnutls.org
Fri Mar 16 23:13:33 CET 2012

On 03/16/2012 11:00 PM, Jim Lloyd wrote:

> Ok, I found the root cause. On this system the shared libraries in 
> /usr/local/lib64 were not being found. This caused some of the
> checks run by ./configure to fail but configure drew the wrong
> conclusions about the failure and produced an incorrect
> configuration. After adding /usr/local/lib64 to LD_LIBRARY_PATH,
> ./configure is able to produce a correct configuration, and gnutls
> builds.

Nice. I also tried to build 2.12.18 on centos 6 and I didn't have the
issues you mentioned.

> There is one unusual error now when running make check: Checking 
> DSA-2048 with TLS 1.0 Failure: Succeeded connection to a server with 
> DSA 2048 key and TLS 1.0. Should have failed! FAIL: testdsa

This is because the libgcrypt back-end. I should have fixed it but it is
low on my priorities because it is not that important (simply ignore
it). If you have nettle installed I'd suggest to use that, especially if
you care about performance.


More information about the Gnutls-devel mailing list