No subject

Wed Dec 5 11:32:35 CET 2012

GNUTLS_BulkCipherAlgorithm gnutls_cipher_get_algo( GNUTLS_STATE 
state); GNUTLS_KXAlgorithm 	    gnutls_kx_get_algo( 
gnutls_mac_get_algo( GNUTLS_STATE state); GNUTLS_CompressionMethod 
gnutls_compression_get_algo( GNUTLS_STATE state); 

IMHO abbrevations ("algo") are bad in the long run, but in this 
case it might better to remove the "_algo" part alltogether (only 
two of the four things are algorithms, the other are 
'methods'). It also makes it consistent with the names of 
gnutls-*-set-priority where "algorithm" isn't used.

(Maybe #define the old names to the new ones for a couple of major 

More information about the Gnutls-devel mailing list