rfc2253-escape-test failed

lfinsto at gwdg.de lfinsto at gwdg.de
Wed Jul 14 12:01:17 CEST 2010

> Sounds like a valgrind problem.  Try 'make check VALGRIND=' or
> ./configure --disable-valgrind-tests.

I tried this:
./configure --disable-valgrind-tests.

and `make check' worked.

Do the tests using valgrind require root permissions? I'm building GNUTLS
as a normal user and therefore couldn't use `make bootstrap', because it
tries to write to /usr/local/bin, etc.  Since the error was "Permission
denied", I thought that might have something to do with it.

I actually invoked configure like this:

 ./configure --disable-valgrind-tests

because I had to install a newer version of libgcrypt than the most recent
one available for OpenSUSE 11.1, namely 1.4.1-4.1  (x86_64).

However, I got the following error, because there was no `-I' option with
the correct path when `[...]/gnutls/lib/gcrypt/init.c' was compiled:

libtool: compile:  gcc -DHAVE_CONFIG_H -I. -I.. -I./../gl -I./../gl
-I./../includes -I./../includes -I./.. -g -O2 -MT init.lo -MD -MP -MF
.deps/init.Tpo -c init.c  -fPIC -DPIC -o .libs/init.o
init.c:36: error: 'GCRY_THREAD_OPTION_VERSION' undeclared here (not in a
make[4]: *** [init.lo] Error 1

I fixed this by copying gcrypt.h and gcrypt-module.h
from /home/lfinsto/libgcrypt-1.4.4/include/ to
`[...]/gnutls/lib/gcrypt/init.c', but this is obviously not a good  solution.

Perhaps it would be useful if I wrote up something to explain how to build
and install GNUTLS as a user without root permissions, but first I would
like to make a branch in the git repository (for this and other purposes).
 I've read some documentation for git, but I haven't quite figured this
out and I don't want to do anything that would mess up the repository.

On the other hand, it wouldn't be necessary if it were possible to pass
appropriate "arguments" to `make bootstrap' (using environment variables,
perhaps).  I've had a quick look at a couple of the Makefile.am files, but
it was not immediately obvious to me how the rules work and what they're
meant to do.

It might also be worthwhile to document  --with-libgcrypt-prefix and
similar arguments to configure in README or READ-alpha.  I wasted some
time fiddling with `CFLAGS', etc., before it occurred to me to read what
`configure --help' output above the description of these variables.


On Fri, July 9, 2010 11:31 pm, Simon Josefsson wrote:
> lfinsto at gwdg.de writes:
>> Hello,
>> I've just cloned the git repository and built the library.
>> make and make install succeeded, but I got the following error with
>> check:
>> valgrind: mmap(0x0, 688128) failed in UME with error 13 (Permission
>> FAIL: rfc2253-escape-test
>> ===================================
>> 1 of 44 tests failed
>> Please report to bug-gnutls at gnu.org
>> ===================================
>> However, when I call [...]/gnutls/tests/rfc2253-escape-test directly in
>> shell, it returns 0.
> Sounds like a valgrind problem.  Try 'make check VALGRIND=' or
> ./configure --disable-valgrind-tests.
> /Simon

Laurence Finston
Gesellschaft fuer wissenschaftliche Datenverarbeitung mbH
Am Fassberg 11
37077 Goettingen

Telefon: 	+49 551 201-1882
E-Mail: 	lfinsto at gwdg.de

More information about the Gnutls-devel mailing list