gnutls_ext_register causing memory corruption

Martin von Gagern Martin.vGagern at
Mon Jun 8 17:50:42 CEST 2009

Simon Josefsson wrote:
> Btw, I installed latest firefox with latest flash 10 plugin, and it
> worked fine on my x86 debian box.  OTOH, my flash plugin doesn't seem to
> link to gnutls at all:

There is strong evidence that flash only depends on gnutls indirectly
via libcurl. If you haven't built libcurl against gnutls, this doesn't
show up. And libcurl is dynloaded, so ldd won't list it.

Please follow the bug reports I mentioned; a lot of people are quite
busy there, gathering evidence, discussing possibilities, stuff like
that. I ruled out concurrent initialization in a comment there.

In the meantime, I'm trying to get a proper git bisect running. I'm not
sure if I can do this, as the problem is difficult to trace. But when
running FF through valgrind and accessing the flash on I just had a 100% rate to reproduce
at least some kind of error, mostly a segfault at application shutdown,
with gnutls 2.8.0, whereas 2.6.6 worked all right. I'll try to reproduce
this with gnutls built from git, and bisect the changes in between.


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 261 bytes
Desc: OpenPGP digital signature
URL: </pipermail/attachments/20090608/a8001512/attachment.pgp>

More information about the Gnutls-devel mailing list