Release candidates of GnuTLS 2.4.3 and 2.6.4

Simon Josefsson simon at
Wed Feb 4 07:35:41 CET 2009

"Douglas E. Engert" <deengert at> writes:

> Simon Josefsson wrote:
>> I have prepared new daily builds containing state-of-the-art fixes for
>> GnuTLS branches 2.4.x, 2.6.x, and 2.7.x:
> Tried compile of 2.6-20090202. What version of libgcrypt11 is required?
> Compile failed to find GCRY_MD_SHA224. I was using libgcrypt11-1.2.4-2Ubuntu-7
> which does not have appear to have SHA224.

Libgcrypt v1.3.0 or later is required, this is the same as for the
entire 2.6.x branch.  If your platform uses the gnutls 2.4.x branch, it
might be better to test it instead.

The dependency on libgcrypt v1.3.0+ isn't critical, but we have to
disable the SHA-2 and Camellia in GnuTLS if libgcrypt < 1.3.0 is used.
This could be done, I think.


More information about the Gnutls-devel mailing list