request for help: openpgp under windows doesn't work

Nikos Mavrogiannopoulos n.mavrogiannopoulos at
Sat Sep 27 20:00:11 CEST 2008

Simon Josefsson wrote:
> "Nikos Mavrogiannopoulos" <n.mavrogiannopoulos at> writes:
>> On Tue, Sep 16, 2008 at 12:58 PM, Simon Josefsson <simon at> wrote:
>>> Windows builds of GnuTLS seem to have some problems in the opencdk
>>> library, which causes parsing of packets to fail.  This can be seen with
>>> the 'pgps2kgnu' self-test, which unfortunately results the same error as
>>> if the problem it is supposed to test for exists (I've made sure the s2k
>>> patch is still working).  The problem appears to be in the low-level
>>> stream reading code in opencdk.
>>> It could be that pgp has never worked under Windows, since the pgp self
>>> tests have been disabled because of missing fork().  I'm inclined to
>>> disable openpgp authentication under windows for the 2.6.x build, and
>>> note in the release notes that it doesn't work currently.
>> I had test the openpgp code in windows a while (year) ago and it
>> worked. I had some issues though, functions like tmpfile() could only
>> be used if run as administrator in windows. Can it be that case?
> I am using wine.  I didn't get a hard failure -- instead I got an EOF at
> a surprising position (middle of stream).  Maybe some fseek problem...
> I suspected binary vs text too, but it looks like the files are opened
> in binary mode.  The idea of using a temporary file seemed somewhat
> strange to me, and I'm not familiar with the code so it was hard to
> debug.
>>> Help in debugging the problem would be appreciated, it is easy to get a
>>> windows build and debug it under debian, see
>>> <>.  I tried to do this, but I'm not
>>> familiar with opencdk and didn't understand exactly how the code was
>>> supposed to work anyway.
>> I might be able to check it within this week.
> Great!
> I had to disable the C++ library too, in order to get a Windows build,
> because the C++ library depends on having all features present.
> Possibly the C++ library could build even if openpgp is missing...
> Still, I think we can release 2.6.0 even with this problem.

Hello Simon,
 I cannot compile gnutls4win, I get:

err:module:import_dll Library libgpg-error-0.dll (which is needed by
not found
err:module:LdrInitializeThunk Main exe initialization for
failed, status c0000135
FAIL: t-strerror.exe
err:module:import_dll Library libgpg-error-0.dll (which is needed by
not found
err:module:LdrInitializeThunk Main exe initialization for
failed, status c0000135
FAIL: t-syserror.exe
2 of 2 tests failed
Please report to bug-gnupg at

If you could commit the latest binaries to cvs or even send them to me
would be the best for me.


More information about the Gnutls-devel mailing list