[PATCH] add gnutls_certificate_find_issuer

Nikos Mavrogiannopoulos nmav at gnutls.org
Thu Feb 21 18:32:47 CET 2008

Simon Josefsson wrote:

> Seems useful.  But what about using *_get_* instead of *_export_* in the
> function names?  The few functions with _export_ in the names appear to
> extract (i.e. copy) the values, but these functions appear to just
> export pointers.  There is also the confusion with export restrictions,
> which some function names with _export_ in them refer to.  So _get_
> might be more appropriate.  What do you think?
> Hm.  Some function names use *_trust* rather than *_cas* too.  Should
> gnutls_certificate_export_x509_cas be gnutls_certificate_get_x509_trust?
> There is a lack of plural there, and we already have one function with
> _cas in it -- gnutls_certificate_free_cas -- so maybe
> gnutls_certificate_get_x509_cas is simpler.

Yes, I also think it is better. I've renamed the _export_ -> _get_. 
However it seems we already have a release with the _export_ names...


More information about the Gnutls-devel mailing list