[gnutls-dev] gnutls-1.0.1 build errors

Dimitri Papadopoulos-Orfanos papadopo at shfj.cea.fr
Mon Dec 15 12:19:49 CET 2003


I'm attempting to build gnutls-1.0.1 on Solaris.

I already have libgcrypt-1.1.90 and opencdk-0.5.3 installed:

$ libgcrypt-config --cflags
-I/usr/local/libgcrypt-1.1.90/include -I/usr/local/libgpg-error-0.5/include
$ opencdk-config --cflags
-I/usr/local/libgpg-error-0.5/include -I/usr/local/opencdk-0.5.3/include

The configure script still doesn't insert all necessary compiler flags 
into a Makefile. Specifically the opencdk inclusion path is missing from 

$ ./configure --prefix=/usr/local/gnutls-1.0.1 \
	--with-libgcrypt-prefix=/usr/local/libgcrypt-1.1.90 \
$ gmake
cc -DHAVE_CONFIG_H -I. -I. -I.. -I../lib -I../libtasn1/lib -I../includes 
    -O -I/usr/local/libgcrypt-1.1.90/include 
-I/usr/local/libgpg-error-0.5/include -c `test -f 'serv.c' || echo 
"serv.c", line 41: cannot find include file: <opencdk.h>
cc: acomp failed for serv.c
gmake[3]: *** [serv.o] Error 2
gmake[3]: Leaving directory `/tmp/gnutls-1.0.1/src'

This issue was worked around by inserting manually into the Makefile:

Then there were the ususal signed/unsigned warnings, see attached build 
log file.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: gnutls-1.0.1.log.gz
Type: application/x-gzip
Size: 14845 bytes
Desc: not available
URL: </pipermail/attachments/20031215/6be015e8/attachment.bin>

More information about the Gnutls-devel mailing list